Eclipse/Ubuntu garść rozwiązań, ale to jeszcze nie koniec.

Jak już pisałem w poprzednich postach Eclipse po zainstalowaniu w Ubuntu nie chce współpracować.
Przeinstalowałem...
Było jeszcze gorzej ;)

Do rzeczy oprócz komunikatów jak poprzednio dostawałem jeszcze błędy samego Eclipse przy uruchomieniu: dzięki wujkowi google skojarzyłem iż problem leży po stronie xullruner, czyli wbudowanej przeglądarki, należało zainstalować nowszą wersję :)  użyłem Synaptic, nowy problem rozwiązany ;)

Komunikat o błędzie podczas uruchomienia przeglądarki wiązał się z tym, że pierwsze uruchomienie niechcący poszło z uprawnieniami admina. Eclipse tworzy folder w katalogu domowym: .mozilla/ecipse który przez sudo należy usunąć, oraz zamienić na wersję "normalną" tzn właścicielem powinien być aktywny użytkownik, tzn np. ja, a nie admin.
Nieciekawy komunikat rozwiązany :)

Pozostało to nieszczęsne kodowanie...
Szukałem, szukałem i znalazłem np. Window->Preferences =>  General->Content Types  na której to stronie można ustawiać kodowanie dla plików danego typu. Wreszczie zapis pliku msgs.properties pozwala na zapis w UTF-8 !!!  Wyjaśniło się też skąd Eclipse bierze te typy plików. Jednak moje emocje szybko ostygły... po uruchomieniu nadal dostaję "krzaczki"...
W pliku properties:  title = Tytuł
A wygląda to tak: TytuÅ‚   

Ma ktoś jakiś pomysł o co chodzi?

PS. Całkiem sporo tych emotikonek w Gmailu ;)

Posted via email from krzychukula's posterous

Comments

Popular posts from this blog

How to simulate slow connection (developer proxy in Node.js)

How to use NPM packages from private repositories on bitbucket